Странное поведение бизнес объекта

Обсуждение Stimulsoft Reports.Wpf
Ответить
Аватара пользователя
Odon01
Сообщения: 28
Зарегистрирован: 19 янв 2015, 07:15

Странное поведение бизнес объекта

Сообщение Odon01 » 27 июл 2015, 11:47

Добавляю бизнес объект следующего вида:

Код: Выделить всё

 public class TiEvents
        {
            public string НазваниеУровень1 { get; set; }
            public string НазваниеУровень2 { get; set; }
            public string НазваниеУровень3 { get; set; }
            public string НазваниеПс { get; set; }
            public string НазваниеТи { get; set; }
            public int НомерТи { get; set; }
            public string ТипТи { get; set; }
            public string ТипСчетчика { get; set; }
            //public int MeterType_ID;
            public string СерийныйНомерСчетчика { get; set; }
            
            public IList<TEvents> События { get; set; }

            public class TEvents
            {
                public DateTime ДатаВремя { get; set; }
                public string Сообщение { get; set; }
                public string ДополнительноеСообщение { get; set; }

                public DateTime ДатаВремяКогдаПолучено { get; set; }
            }
        }
В дизайнере получаю следующее:
Проблема по бизнес объекту.png
Проблема по бизнес объекту.png (18.97 КБ) 1768 просмотров
Откуда под "События" взялось "Item"?
Из-за этого не строится отчет.

Использую версию 2015.1
HighAley
Сообщения: 1979
Зарегистрирован: 08 июн 2011, 07:36

Re: Странное поведение бизнес объекта

Сообщение HighAley » 28 июл 2015, 12:46

Здравствуйте.

Мы сделали фикс данной проблемы.
Теперь дополнительный объект не создаётся.
Проверьте, пожалуйста, наш следующий билд от 31 июля.

Спасибо.
Аватара пользователя
Odon01
Сообщения: 28
Зарегистрирован: 19 янв 2015, 07:15

Re: Странное поведение бизнес объекта

Сообщение Odon01 » 28 июл 2015, 15:36

Здравствуйте.
Спасибо за ответ. Но мы используем только ваши исходники, т.к. у нас свой набор ф-ий чтения данных. И у нас своя особенность работы с xbap. Подскажите пожалуйста как мне внести ваши исправления.

Спасибо.
HighAley
Сообщения: 1979
Зарегистрирован: 08 июн 2011, 07:36

Re: Странное поведение бизнес объекта

Сообщение HighAley » 29 июл 2015, 11:16

Здравствуйте.

Пришлите, пожалуйста, запрос на support@stimulsoft.com с вашими регистрационными данными.

Спасибо.
Ответить