Отчет отображается в дизайнере, но не отображается на сайте

Обсуждение Stimulsoft Reports.Java
igorevd3
Сообщения: 13
Зарегистрирован: 11 авг 2015, 08:24

Отчет отображается в дизайнере, но не отображается на сайте

Сообщение igorevd3 » 12 сен 2015, 14:45

Добрый день. Имеется некоторая проблема:
В дизайнере некоторый отчет (приложен) показывается нормально. Тот же самый отчет и тот же самый xml на сайте показывают пустую страницу. (при этом по большей части приведенный отчет с другими данными на сайте показывается нормально).

https://cloud.mail.ru/public/8Uz6/kvJhvkfsT
HighAley
Сообщения: 1955
Зарегистрирован: 08 июн 2011, 07:36

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение HighAley » 14 сен 2015, 09:11

Здравствуйте.

Отображаются ли другие отчёты на сайте?
Какой вьювер вы используете? Какую версию нашего продукта.
Как вы подготавливаете отчёт для вьювера?
Пришлите, пожалуйста, больше информации по данной проблеме, чтобы мы смогли помочь вам.

Спасибо.
igorevd3
Сообщения: 13
Зарегистрирован: 11 авг 2015, 08:24

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение igorevd3 » 14 сен 2015, 10:05

Добрый день.
1. Другие отчеты отображаются. Более того, даже этот отчет иногда отображается, хотя зависимость установить не удалось.
2. Используем HTML
3. Версия от 13.10.14
4. Создаем xml с данными, кладем на диск и запускаем вьювер подавая ему на вход файл шаблона и файл данных. (оба файла в приложенном архиве - это ровно те же самые файлы. Т.е., xml скопирован с диска сервера).
HighAley
Сообщения: 1955
Зарегистрирован: 08 июн 2011, 07:36

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение HighAley » 14 сен 2015, 10:51

Здравствуйте.

Было сделано уже очень много доработок.
Обновитесь, пожалуйста, до нашего последнего билда и сообщите нам о результатах.

Спасибо.
igorevd3
Сообщения: 13
Зарегистрирован: 11 авг 2015, 08:24

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение igorevd3 » 17 сен 2015, 11:04

Добрый день.
Установили самую последнюю версию (скачивали позавчера) - не помогло.
Andrew
Сообщения: 547
Зарегистрирован: 09 июн 2006, 08:22

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение Andrew » 17 сен 2015, 14:08

Здравствуйте,

Спасибо за ответ. Перепроверим все.

Спасибо.
igorevd3
Сообщения: 13
Зарегистрирован: 11 авг 2015, 08:24

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение igorevd3 » 21 сен 2015, 11:34

Добрый день.
Какие перспективы решения проблемы?
Vadim
Сообщения: 97
Зарегистрирован: 04 апр 2013, 08:26

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение Vadim » 22 сен 2015, 07:55

Здравствуйте.
Ваш отчет одинаково отображается в дизайнере и во вьювере.
Возможно вы не запускаете .render() отчета перед передачей его в параметры jsp тега.
igorevd3
Сообщения: 13
Зарегистрирован: 11 авг 2015, 08:24

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение igorevd3 » 22 сен 2015, 14:10

Добрый день.
Разумеется мы запускаем render. Более того, в некоторых случаях (при некоторых наборах данных) отчет выводится.
вот здесь https://cloud.mail.ru/public/3D1h/gmP2Dj9Gr еще один архив, который содержит отчет непосредственно с сайта (уже подставлен путь к реальному файлу данных), файл данных с сервера и stacktrace выполнения, в котором видно, что валится по null pointer . Вот только в дизайнере все нормально работает.
Vadim
Сообщения: 97
Зарегистрирован: 04 апр 2013, 08:26

Re: Отчет отображается в дизайнере, но не отображается на са

Сообщение Vadim » 23 сен 2015, 06:25

Здравствуйте.
Ваш отчет отображается нормально.
Но строчки шибки в с присланном стеке не совпадают с реальными исходниками, скорее всего у вас старая версия.
Последняя версия: Stimulsoft Reports.Java 2015.1.21 from 2015.09.11
Вложения
zxc.PNG
zxc.PNG (59.81 КБ) 2328 просмотров
Ответить